Kaavat

Kehäviittauksen etsiminen ja poistaminen

Kehäviittauksen aiheuttavan solun etsiminen Excel 2010:ssä.

Kehäviittaus tapahtuu, kun jonkin solun kaava viittaa alueeseen, johon se itsekin kuuluu joko suoraan tai epäsuorasti.

Yleisin kehäviittaus aiheutuu Summa-kaavasta, esimerkiksi

=SUMMA(A1:A5)

kun kaava on kirjoitettu soluun A5.

Isoissa taulukoissa kehäviittaus saattaa olla vaikeahko löytää. Excel 2010:ssä on kuitenkin siihen helppo työkalu.

1

Valitse työkaluriviltä Kaavat-välilehti

(kuvat aukeavat isompina klikkaamalla)

kehaviittaus-1
2

Kaavan tarkistaminen -osiosta löydät virheentarkistustyökalun.

Klikkaamalla painikkeen reunassa olevaa nuolta ja valitsemalla avautuneesta valikosta Kehäviittaukset, löydät taulukon kehäviittauksien sijainnit.

kehaviittaus-2

Kun olet löytänyt kehäviittauksen sisältävän solun, voit tarkistaa onko kaava niin kuin olit tarkoittanut.

Kirjoittajasta

Tommi Honkala

Pienyrittäjä, tietojenkäsittelyn tradenomi, Excelin pyörittelijä ja yleisnörtti PK-seudulta.

Kommentoi

This site uses Akismet to reduce spam. Learn how your comment data is processed.